NextGEN Gallery v1.5.0 Release candidate 1

14Mar10

I fixed a couple for bugs for Post Thumbnails support and also added a new auto downloader for translation files. This is now the last version before I will uploaded it to wordpress.org. If nobody reports a big problem, I expect to release it in one week.

Help testing now … Thanks !

24 Responses to “NextGEN Gallery v1.5.0 Release candidate 1”


  1. Gravatar Icon 1 Arne Posted March 15th, 2010 - 10:20

    Es gibt eine Fehlermeldung, die ich bei der vorigen Version nicht hatte: irgendwas in Line 216 passt nicht. Dass das Rendering vom template=compact nicht funktioniert (vielleicht ja auch nur bei mir, wer weiß?!) ist also nichts Neues. Dass aber auch das rendering vom template=extend nicht klappt, ist durchaus neu…

    Trotzdem: eigentlich ist Nextgen klasse. Wenn ich es nur richtig zum laufen kriegen würde.

    Viele Grüße aus dem Harz!

  2. Gravatar Icon 2 alex.rabe Posted March 15th, 2010 - 10:30

    Hast du mal ein Link zu dem Problem , damit ich mir das anschauen kann. Welchen Shortcode nutz du ?

  3. Gravatar Icon 3 foobar Posted March 15th, 2010 - 13:10

    Hi,I would to use this plugin in a project,but afraid the code into head looks too dirty: inline js messages and such. How could I leave cleaner without touch plugin core,please? Also I added ngg widget to show one random image in my header,then getting a lot of html, js generated, that is let my css hard to work.Am I following a wrong method? Thanks.

  4. Gravatar Icon 4 Arne Posted March 15th, 2010 - 16:01

    Ich muss zugeben, dass ich den RC einfach gelöscht und die letzte stabile Version wieder installiert hab. Nachdem ich die komplette Zeile einfach gelöscht hatte, war auch das Problem weg…

    Was meinst du denn mit “Shortcode”?

  5. Gravatar Icon 5 Joshua Been Posted March 15th, 2010 - 21:41

    I think there is a small bug in the sort order part of your gallery. I try to do date/time descending and it bugs back to the gallery instead of updating the sort order. very frustrating. Great Gallery besides that, and thank you.

  6. Gravatar Icon 6 alex.rabe Posted March 15th, 2010 - 21:49

    @Josuha Is this a new problem with V1.5.0 ?

  7. Gravatar Icon 7 andy Posted March 15th, 2010 - 23:21

    is there any way to remove the “view with piclense”? Thank you!

  8. Gravatar Icon 8 alex.rabe Posted March 15th, 2010 - 23:22

    see options

  9. Gravatar Icon 9 Lule Posted March 16th, 2010 - 09:28

    Hi, first THANKS FOR THIS GREAT PLUGIN!!
    Following Problem. We use WPMU 2.9.2 the actual version of the gallery as well as the RC don’t create the necessary user tables when we create new blogs over the dashboard.
    Any suggestions?

  10. Gravatar Icon 10 alex.rabe Posted March 16th, 2010 - 09:49

    Yes, don’t use this plugin under WPMU. I’ve need to rework it for WPMU.

  11. Gravatar Icon 11 foobar Posted March 16th, 2010 - 10:10

    Hi,solved issue by dont use random photo widget at all.peace.

  12. Gravatar Icon 12 Lule Posted March 16th, 2010 - 10:59

    Ok thanks for the Help. Found out, that if I don’t activate the Plugin sitewide but manually for each new blog itself it works just fine.

  13. Gravatar Icon 13 Mixa Posted March 16th, 2010 - 16:54

    Sorry, off topic.

    The option “Integrate slideshow” defective. I can not disable the slideshow. Also, for some unknown reason is not replaced with the inscription “View with PicLens”. How to fix this?

    http://clip2net.com/clip/m5763/1268731429-clip-10kb.png

  14. Gravatar Icon 14 Derek Posted March 16th, 2010 - 21:33

    nextGEN set up and Slideshow & Album work OK but i’m getteing “Gallery Not Found” on the following tags

    [slideshow id=volunteers]

    [album id=voulunteers template=extend]

    [nggallery id=volunteers]

    Any ideas what I have done wrong )Page link is set up.

  15. Gravatar Icon 15 Vincent Posted March 17th, 2010 - 23:46

    Hey Alex,

    Because I like your programming style and in the need for an example plugin, the past few days Im digging quit deep into this plugin.

    Untill now i do understand almost every piece of code of it but in the nggLoader class inside the start_plugin method, I cant figure out what you want:

    // Load the admin panel or the frontend functions
    if ( is_admin() ) {

    // Pass the init check or show a message
    if (get_option( ‘ngg_init_check’ ) != false )
    add_action( ‘admin_notices’, create_function(”, ‘echo \’‘ . get_option( “ngg_init_check” ) . ‘\’;') );

    } else {
    //..

    Am I missing something?

  16. Gravatar Icon 16 pao Posted March 19th, 2010 - 04:04

    Muchas Gracias !!!!! Thank you so much ;)

  17. Gravatar Icon 17 Mike Posted March 21st, 2010 - 13:04

    Hallöchen,

    ich bekomme nach dem Update auf 1.5.0 einen Fehler 500 wenn ich mein WordPress aufrufe. Wenn ichdes NextGen deaktiviere läuft die Seite einwandfrei. Hast Du eine Idee ??

    Läuft auf einem Windows 2008 Server, mit IIS 7.0 unter php 5.2.6

  18. Gravatar Icon 18 oovaoosh Posted March 23rd, 2010 - 22:27

    When I upgrade to 1.5.0 my flash upload doesnt work any more. When I choose pic and gallery then press upload and have error message. :( Help :(

  19. Gravatar Icon 19 donna Posted March 24th, 2010 - 17:53

    There seem to be a problem with the thumbnails, I can’t edit. It always tell me error in updating. When I uploaded the files, it also gave me an internal server error? there’s nothing wrong with the server. I checked that the files are all uploaded and not broken, BUT it can’t seem to create a THUMBNAIL… i’ve experience this problem a couple of times, and it’s always the thumbnails that are acting weird. my version 1.5.1

  20. Gravatar Icon 20 Timo Posted April 1st, 2010 - 15:14

    The sorting of images within the galleries does not work. i updated from 1.1 because i thought it would fix the problem, but 1.5.2 will not allow me to sort the images to my own taste either :s When you click on update sort methid it just defaults back to the unsorted way they were before i ordered them… I saw a fix online for changing the ngg-db.php file with this:

    // Check for the exclude setting

    $ngg_options = get_option(‘ngg_options’);
    $gal_sort = $ngg_options['galSort'];
    $gal_sort_dir = $ngg_options['galSortDir'];

    if ( $gal_sort_dir == ‘RAND’ ) {
    $order_clause = ‘ORDER BY rand() ‘;
    } elseif ( $gal_sort_dir == ‘DESC’ ) {
    $order_clause = ‘ ORDER BY t.’.$gal_sort.’ DESC’;
    } else {
    $order_clause = ‘ ORDER BY t.’.$gal_sort.’ ASC’;
    }

    But i t doesnt seem to work either so any help on this please?

    Thanks very much

    Timo

  21. Gravatar Icon 21 SEANJACOB Posted April 6th, 2010 - 16:04

    I also have found the bug in the sort order part of your gallery. I try to do date/time descending and it bugs back to the gallery instead of updating the sort order.

    And I am using Version 1.5.2

    Is it possible in the ngg-widget to show your images by your order not by random or recent added?

    Very good plugin used through out my site.

  22. Gravatar Icon 22 therealrob Posted December 22nd, 2010 - 23:14

    Hi Alex,

    I use your plugin (v1.5.5) on WPMU v2.9.2 and it has been working beautifully until on 1 blog the “View with PicLens” button decided not to work anymore in FF and Chrome. In IE8 the PicLens screen comes up but doesn’t load the images. Do you have any idea as to what could be causing this on 1 single blog?

    Thanks in advance.

  23. Gravatar Icon 23 therealrob Posted December 23rd, 2010 - 19:57

    Nevermind…It was a domain mapping issue. The mapped URL (from the domain mapping plugin) wasn’t set in the blog options page for the site url and home url options.

Who's linking?

  1. 1 WordPress Podcast: Inside Look at Web Hosting - Programming Blog Pingback on Mar 31st, 2010
    "[...] NextGen Gallery also had an update [plugin] [...] "
Comments are currently closed.