New bugfix release

In this minutes I’ve uploaded a new bugfix release NextGEN Gallery Version 1.5.2 . There is one XSS bug fixed in the media-rss script and I also solved a  issue with old shortcodes. I encouraged everybody to update to the latest version, or if you on whatever reason stay would stay at your version, please  update the file media-rss.php from here : http://code.google.com/p/nextgen-gallery/source/detail?r=718

Please report further problems in the forums, thanks !

Tagged ,

34 thoughts on “New bugfix release

  1. Hazel R says:

    Hi, i dont know too much but I notice after I upload images and it is doing the thumbnails it crashes and my screen gets filled with garbage symbols. any suggestions

  2. Redacter says:

    I love this plug-in. It does everything I need it to do but one thing. It does not generate a page view when someone clicks on a thumbnail to expand the photo to a full page size.

    This is a critical feature for those of us.. and there are many… who live and die by page views.

    I would use this otherwise. Right now I hard code photo galleries, using static pages and thumbnails within the article. When you click on a thumbnail it takes you to the static page, and records a page view.

    Is there anyway to add this feature to next gen? It would exponentially increase its popularity.. Haven’t found a photo plug in yet that can do this…

  3. amedeo says:

    hi,
    thx for all.
    just a question: is there an “official” procedure to fix imagerotator.swf path issues?
    thx again

  4. jjhealy says:

    If i upload a zip file with filezilla, what file do I place it in to connect with next gen, or can anyone direct me to a good explanation of this. Sorry this may be the wrong place to ask but i seem to be bogged down attempting to make this connection

  5. Heidi says:

    Hi there, thanks for the great plugin. I am wondering if there is a way to order the display order of my images in a gallery? I need them to be in a specific order (step 1, 2, 3) and I cannot seem to get them in the correct order. Any suggestions would be most helpful!

    Thanks!

  6. Laurens says:

    Hi,

    Great plugin, I’ve been using it for a few months now.

    However, the latest upgrade caused a lot of problems – I get wierd symbols when I try to do anything, , and finally my website went blank.
    As I was doing a number of different things, I couldn’t work out what caused the problem, but I just reinstalled wordpress and started from scratch and it seems doing the NextGEN upgrade to 1.5.2 causes the problems.

    Thanks.

  7. Laurens says:

    Hi,

    Just been trying to isolate this problem, and maybe it isn’t to do with nextgen, as it seemed to work ok second time.
    I’m having to uninstall/reinstall each plugin individually to work out which is the trouble maker.

    Will let you know what caused it if I work it out.

    Thanks.

  8. Brian says:

    Anyone else receiving error after upgrading? I have the slideshow feature showing in the header of several websites and all show

    [Gallery not found]

    Any suggestions on how to fix would be much appreciated.

  9. Laurens says:

    Hi Brian, I have the same.
    All my links to photos have failed([SinglePic not found]), and if I click on gallery from my wp admin it says 0 pictures and 0 galleries.
    My website is now a disaster. I don’t think the problem I mentioned above was a NextGEN fault, but I have been unable to replicate it by installing each of my plugins individually.

    Any suggestions on how I can reconnect my pictures and the associated labels would be great.

  10. Roulion says:

    Hi,

    After an upgrade of the 1.5.2 version, in all articles where i used the tag [nggallery=X], the gallery is displayed before the text. You can see it here : http://www.vacances-cosy.fr/2009/11/11/dans-les-faubourgs-de-vienne/

    In yhis article, i have 3 galleries related to the paragraphs.
    Thanks for your help

  11. Brian says:

    Laurens,

    My galleries and everything are still intact, I just can’t seem to get the pics to show up on the front end of my sites. I have linked mine back to NextGen, prior to updating one of my sites everything was working perfectly, once I ran the update my pics went missing. Hope they have some kind of a fix soon.

  12. Jan says:

    Hi Alex,

    Great plugin, I’m currently testing it to replace Gallery as my, well, gallery software. One thing that gave me a sour taste with this update was that it deleted the custom CSS and template files that I had created for my website. Don’t know if this is the WordPress plugin update behaviour, but if possible, please just update the original files and not just replace the entire folder, thereby deleting all custom CSS / template files.

    Jan

    PS. Redacter: go to the WordPress admin, NextGen Gallery options, then the Gallery tab, and check ‘Show Imagebrowser’. Clicking on thumbnails should now generate a pageview.

  13. alex.rabe says:

    @Jan

    Store custom templates in your theme folder :

    http://nextgen-gallery.com/templates/

  14. Jan says:

    Hi Alex,

    Thanks. Does that also work for CSS files??

    Jan

  15. alex.rabe says:

    Yes , if you named it nggallery.css

  16. Jackson25 says:

    Hi – awesome plugin!

    I’ve installed the NextGen Gallery plugin and it works fine. How do I install the nggGalleryview plugin? Do I just upload it to a certain directory?

    Thanks for your help!

  17. Is anyone else seeing issues with Tags not coming through when uploading the photos from Windows 7?

  18. SEANJACOB says:

    I also have found the bug in the sort order part of your gallery. I try to do date/time descending and it bugs back to the gallery instead of updating the sort order.

    And I am using Version 1.5.2

    Is it possible in the ngg-widget to show your images by your order not by random or recent added?

    Very good plugin used through out my site.

  19. Jessica says:

    also i keep getting an error message. exhusted on line933 for the lib file in thumbnail. it is really odd since my images are downsized.

  20. steven says:

    hello. i use goggle chrome. i have this gallery installed on my webpage and thought i have a bug.

    every time i click on an image it displays fine.
    BUT the second time i click on an image the browser turns black and it says loading.

    i now see the same problem right here on this page when clicking on the images. is that only my pc or only chrome.
    what can we do about that?

    please help guys.
    but i love the gallery. thanks Mr. Raven fuer diese tolle arbeit.
    steven

  21. Wenn Du im File shutter-reloaded.js
    in Zeile 196
    shHeight = t.wHeight – 50;
    anstatt
    shHeight = t.wHeight – 7;
    schreibst, dann erscheint das ganze Bild inklusive den Pfeilen.

  22. alex.rabe says:

    @Werner
    Danke für den Tip !

  23. Jana says:

    Seit dem letzten Update funktioniert die Darstellung in FF nicht mehr. Die Fotos stehen nicht mehr nebeneinander sondern untereinander. Im IE dagegen wird alles korrekt dargestellt….
    VG jana

  24. Klaus says:

    I noticed that there’s a conflict in combination of plugins, causing to show only one comment per page in the Admin area

    These plugins are:
    Nextgen Gallery (Alex Rabe)
    WordTwit (Dale Mugford & Duane Storey (BraveNewCode))
    WpTouch (Dale Mugford & Duane Storey (BraveNewCode))
    WP Email (Lester Chan)

    I notified the others as well. Any idea?

  25. Omer says:

    Nextgen gallery shutter reloaded does not work with firefox 3.6.
    Even on your demo site http://nextgen-gallery.com/ the problem exists. Click on an image, and it’ll throw you all the way to the top of the page. How can we fix this?

  26. br1 says:

    hi!

    i made a simple change to the NextGEN sidebar widget configuration, so it allowes a free input field of the number of images to display. the dropdown of 1-10 is quite an arbitrary limit, imho…

    can you please checkout this patch?

    http://br1.einfach.org/tmp/nextgen-config-number-input.diff

    and – thanks for this nice plugin!

    bruno

  27. Tina says:

    Hi I really like this plugin, my web developer is having problems using the sparkles gallery when he tries to install it it says ‘Could not found monoslideshow.swf, please verify the path or upload the file’ do you know how this can be fixed

    Thanks

  28. Brian says:

    No thumbnails showing up in gallery. I have used this plugin for a while and I love it. Really awesome. I run into an issue now though. At a certain point, my new galleries no longer display thumbnails. On the server, they are there, but they do not show up on the site or in the admin area. Please see this page:

    http://millwood.us.com/business/photo-gallery/filingstorage/

    The following is a good one:

    http://millwood.us.com/business/photo-gallery/seating/

    Any suggestions? How can one gallery work on the same site and others don’t? All details were the same when creating all of them.

    Please help.

    Thank you,
    Brin

  29. foobar says:

    Hi.can you please me explain why NGG that i like so much in its serverside structure got a unmanageable html structure? what is the purpose to have div a img | a img | a img instead a normal ul li a img and ul li a img span in case of description? I cannot styling it as i would if the structure is a nightmare.And sincerely it is a pity.
    regards
    alberto

  30. Nor says:

    Hi
    I’ve got the same problem as here – http://wordpress.org/support/topic/389837. Could you tell where can I find connections between albums and galleriws in sql or files, so I could connect it manualy?
    N.

  31. Georg says:

    Hi Alex,
    vielen Dank für das wundervolle Plugin. Ein kleines Problem habe ich derzeit mit dem Flash-Fileuploader. Da die Bilder die Endung .JPG haben (und vermutlich, weil meine Webseite auf einem Linux-Server drauf ist), zeigt er die großgeschriebene Variante nicht an, sodass ich die Bilder erst umbenennen muss, um sie hochladen zu können.
    Für mich ist das kein Problem, aber einige andere Nutzer auf meinem Blog können das nicht massenweise hinkriegen bzw. es stellt eine Hürde dar.
    Könntest du den file-extension-filter um die großgeschriebene Variante erweitern?

    Wär dir sehr dankbar :D

    Liebe Grüße,
    Georg

  32. mitch says:

    Alex,

    I started a thread on the forums. I’ve tried for the last week to get the pagenation working on a gallery. I went back to follow up and the issue thread #296 is gone. Do you have any insight on what the problem could be or is? The link is here (http://bit.ly/aeQ6DU)
    and the gallery is at the bottom of the post.

    Thanks

  33. jeff says:

    Hey Alex,

    Is there any setting to use so that I can pull a random image from a gallery to use as the “Preview Image”? Right now I don’t have a Preview Image set for any galleries, but without the Preview Image, the post just looks weird. Thanks!!

  34. flavio says:

    dear alex,

    First of all, i’ve tried your Nextgen plugin on wordpress and i loved it!! it’s perfect!! congratulations.

    My question is about a “joomla” version of Nextgen. Do you intend to do something like this? If not, do you know any joomla plugin that does the same thing as your nextgen? (with upload frontend, gallery creation/management, etc,…)

Comments are closed.