Release of NextGEN Gallery 1.9.0

27Nov11

WordPress 3.3 is coming with big steps, so it’s time to update NextGEN Gallery. As said in my previous posts, I’ve included Plupload to this plugin as soon as you jump to WordPress 3.3 version. Moreover I fixed a couple of bugs. Here is a short list :

  • NEW : Keep images transparency for PNG and GIF format
  • NEW : Switch to Plupload, support now HTML5 Upload (only with WordPress 3.3)
  • NEW : Added client side resize feature (only with WordPress 3.3)
  • NEW : Support for gallery templates in album shortcodes [ album id=x template="name" gallery="templatename" ]
  • NEW : Added new hook ngg_delete_picture
  • Changed : Updated to jQuery Cycle Version 2.9995
  • Changed : Always cache the single pictures, remove option
  • Bugfix : Couldn’t use bulk operation for serach results
  • Bugfix : Bugfix for Edit thumbnails under IE 8 + 9
  • Bugfix : Allow empty altext in ngg.editImage
  • Bugfix : Various PHP notice fixes
  • Bugfix : Resize fix for Shutter effect and mobile Browser
  • Bugfix : FTP Import missing slug field into database
  • Bugfix : Check also EXIF field “DateTimeOriginal” for timestamp

Download NextGEN Gallery Version 1.9.0
Release Version @ wp.org

48 Responses to “Release of NextGEN Gallery 1.9.0”


  1. Gravatar Icon 1 ballet news Posted November 27th, 2011 - 12:31

    Sine upgrading the plugin this morning I cannot get the page ‘add galleries’ This is a serious problem for me.

    Please can you tell me what’s gone wrong and how to fix it ? I have an urgent requirement to get a gallery uploaded by tonight. thanks

  2. Gravatar Icon 2 Alex Rabe Posted November 27th, 2011 - 12:32

    Please post any question in the forums . Thanks !

  3. Gravatar Icon 3 ballet news Posted November 27th, 2011 - 12:43

    Would really appreciate a response though – this is a major issue !

  4. Gravatar Icon 4 Bartolomeo Di Monaco Posted November 28th, 2011 - 17:22

    I too have the same problem with NextGen Gallery. I have WordPress 3.2.1.
    Do not scroll through the photo galleries.

    Bartolomeo Di Monaco – Italy

  5. Gravatar Icon 5 Kathy Posted November 28th, 2011 - 18:22

    I’m needing to update my header but do not have the option to see “Header” under Custom Header. I’m currently using 3.2.1.

    Please advise – Thank you.

  6. Gravatar Icon 6 Noixdarec Posted November 28th, 2011 - 19:25

    One more suggestion: the plugin does capture the geocodes (latitude, longitude) from EXIF, which is great! But these data are put into photo descriptions. Could it be possible to
    1. Put them in separate fields,
    2. and put them in generated XMLs
    For further uses such as working with Google Maps it would be very very useful.

    Please have a look at my testing page:
    (pic paths and titles are from xml generated by NextGen, but the geo locations are entered by hand for now)
    http://blog.hyperreel.net/?p=2461&lang=en

    Best regards,

    Noixdarec

  7. Gravatar Icon 7 Angi Wiggins Posted November 28th, 2011 - 22:56

    Since upgrading the plugin this morning I cannot get the page ‘add galleries’ either!

  8. Gravatar Icon 8 Kevin D. Shank Posted November 29th, 2011 - 03:08

    Problem adding images. I upgraded this morning.

  9. Gravatar Icon 9 Bachsau Posted November 29th, 2011 - 15:16

    Pagination and Slideshow doesn’t work anymore. Fuck off!

    http://www.krawallursache.de/reisen/tuerkei-2011/

  10. Gravatar Icon 10 Bachsau Posted November 29th, 2011 - 15:26

    Hmmm, seems to work again after editing the page. Maybe there’s a bug in Nextgen Gallery when using quick edit on pages? I just used quick edit to change the page order, and that seems to have broken the gallery.

  11. Gravatar Icon 11 Caj006 Posted November 29th, 2011 - 16:28

    Any chance you can give NextGen the ability to implement videos into a gallery in addition to images? I know tons of people have been asking for this over the last couple of years. Is there a plan to ad this or is this never going to be a consideration for NextGen?

  12. Gravatar Icon 12 rivo Posted November 30th, 2011 - 19:27

    Since the update, I can’t load images to galleries, it says the gallery does not exist. Using wordpress 3.2.1. I urgently need a fix for this bug — or how to revert to the previous version!!

  13. Gravatar Icon 13 rivo Posted November 30th, 2011 - 19:36

    On further research, my “non-existent” galleries were the ones still empty — deleting and recreating the gallery seems to work. And I seem to be able to normally add images to the galleries with pictures.

  14. Gravatar Icon 14 Ronny Posted December 1st, 2011 - 05:46

    Since I cleared my cache the SinglePic functionality in pages is not working anymore – i run the lates version and removed and inserted several pictures as “SinglePic” in the page but the picture does never show up. Any idea what is broken? I use IE 9

  15. Gravatar Icon 15 chatychaty Posted December 1st, 2011 - 10:36

    Please can you tell me what’s gone wrong and how to fix it ? I have an urgent requirement to get a gallery uploaded by tonight.

    Thanks
    chatychaty

  16. Gravatar Icon 16 Bachsau Posted December 1st, 2011 - 20:18

    @Caj006: I’m using JW Player plugin to display videos on my blog. It’s as easy to set up as NextGEN Gallery. Give it a try!

  17. Gravatar Icon 17 Kevin Posted December 4th, 2011 - 13:54

    If I enlarge my thumbnails they look blurry and stretched in Firefox. I have posted in the forums, but no reply. Do I have to make a donation to get this fixed? Am I the only one with this issue??

  18. Gravatar Icon 18 Juan Posted December 5th, 2011 - 12:57

    Hello:

    Very good plugin; but i can’t activate it. The plugins page turns white when i activate it.

    I have installed the Lightbox plus plugin and when i turn off it i can activate the NextGEN Gallery. But the problem is i need both plugings.

    Can you help me activating it? Thanks!

  19. Gravatar Icon 19 Omar Posted December 6th, 2011 - 20:37

    Was hoping that this would finally fix, once and for all, the issue of adding text under the thumbs. Using [nggallery id=1 template=caption] never worked for me, no matter what theme I used.

  20. Gravatar Icon 20 Mendim Posted December 9th, 2011 - 14:14

    Hello,today i open my site and kaspersky internet security display a notification for trojan in this file
    wp-content/plugins/nextgen-gallery/images/rollover.php

    i open that file i see encoded data

  21. Gravatar Icon 21 csmillio Posted December 9th, 2011 - 19:10

    I am experiencing what may appear to be a glitch in the program. When I attempt to upload photos to create a gallery–the screen goes blank and nothing displays at all. There is no way that I can upload photos to continue using Nextgen….Please help me figure this plugin out. It seems to be more of my taste than the others and I prefer using Nextgen.

    Thanks,

    csmillio

  22. Gravatar Icon 22 Diego Posted December 12th, 2011 - 13:08

    Hiho,
    the new version still seems to have the old bug with displaying albums in internet explorer. The thumbnails keep getting displayed as “stripes” (also in the standard wordpress theme).

    The solution for me was to put the width and height directly into the thumbnail’s CSS.

    The solution in detail can be found here:
    http://www.diegos.de/blog/2011/08/bugfix-fur-nextgen-gallery/

    Greetings,
    Diego

  23. Gravatar Icon 23 F Scheltens Posted December 13th, 2011 - 22:11

    Request:

    would it be possible to make the tags like [nggtags gallery=part-1] show the images in the same order in which they appear in the gallery?
    I currently use this to show specific photo´s from one gallery in one part of my post, and other photo´s further down. (I don´t use separate galleries for everything to keep the number of galleries manageable.)
    The problem is that i have image-10.jpg preceding image-2.jpg, which i don´t want.

  24. Gravatar Icon 24 vivi Posted December 14th, 2011 - 06:23

    rivo i have the same problem with u.

    after upgrading to version 3.3 i cant upload images to gallery. do u have the solution to it already?

    appreciate if someone could help. thanks

    vivi

  25. Gravatar Icon 25 copacetic Posted December 15th, 2011 - 01:25

    will there be a native comments system introduced to the new Nextgen Gallery, particularly one that allows comments on individual photos? Or is that a concern for other developers to deal with?

  26. Gravatar Icon 26 Norman Apalis Posted December 21st, 2011 - 06:01

    Fantastic plugin! Slideshow Widget could use some love though. Any chance for some development in that area to make it more efficient and robust? Many thanks!

    Needing something to address the little things from this post here:

    http://wordpress.org/support/topic/plugin-nextgen-gallery-use-thumbnails-and-alttext-in-ngg-js-slideshow-widget

    Much appreciated!

  27. Gravatar Icon 27 Ana Posted December 27th, 2011 - 18:53

    After all updates I still cannot use Thumbnail Editor – interestingly, left side is either blank or black – both in FF but on different websites. IE simply does not display any image – just a little red cross. This is extremely frustrating and while looking for help, I can see that I am not the only one – unfortunately, no help available.

  28. Gravatar Icon 28 todayweekly Posted January 3rd, 2012 - 12:06

    1、NextGEN Gallery can’t solve the larger pic such as 983*1406 ?

    and why the name of the pic will be changed after it’s uploaded ?

    thanks!

    2、 sometimes,it can not find the pictures uploaded by ftp

    3、if pictures can be zoomed some percent which is I designed ,that will be attractive

    thanks ,happy new year.
    James

    754615159@qq.com

  29. Gravatar Icon 29 Achim Posted January 7th, 2012 - 17:09

    Hallo,
    ich kann keine Galerie mehr über den Artikel-Editor einfügen. Wenn nman den Button:”Wähle oder suche Galerie” drückt, läuft das warten Zeichen und nichts mehr passiert. Ich muss die Galerien jetzt Handisch eingeben. Bilder oder Album einfügen geht auch nicht.
    War glaub ich auch schon vor dem Update. Ging aber schon…
    Gruß Achim

  30. Gravatar Icon 30 Nick Posted January 7th, 2012 - 17:30

    Are you available for freelance work? Need S3 support. true s3 support. Email me?

  31. Gravatar Icon 31 Christian Posted January 10th, 2012 - 11:24

    I am trying to restore my NGG tables from a backup, but when I do, even though those restored galleries and photos are functional again, I lose the ability to create new galleries and to add new images to existing galleries. When I attempt to add a gallery, it is created on my server, but Nextgen does not recognize it. The backup is from a previous version (though I don’t know which) of Nextgen and someone suggested it may be a database issue with a reference to the older version. I don’t know where to look. I’ve tried to ask for help in the forums, but no avail…only other people with a similar problem. Anyone have a suggestion? Thanks. ~C

  32. Gravatar Icon 32 Free Bird Posted January 12th, 2012 - 17:17

    It’s a reality : the last update HAVE A BIG PROBLEM and it is not the wordpress forum witch can resolve it.

    I use NEXTgen gallery before it, never problem. I have update WP to 3.3, no souci. But I have update NEXTgen and it’s impossible to load images, or with some and some difficulties.

    Please, can you publishing an update for correct the bugs ?

    Thank you. It’s urgent for all the NextGen users.

  33. Gravatar Icon 33 Q Posted January 16th, 2012 - 17:56

    It seems not support IE6

  34. Gravatar Icon 34 George Posted January 17th, 2012 - 17:48

    Hello,
    Does anyone know a way to include a link that would show all the images within a gallery?

    We currently have the pagination set, but the client wants to have an option to show all.

    Any help would be greatly appreciated.

    Thanks,
    George

  35. Gravatar Icon 35 inge Posted January 24th, 2012 - 16:01

    Reading about all this problems with updating NextGEN Gallery I simply don’t have the guts to do it. I don’t have the time for this kind om problems. Please let us all know when you have an update that performs well in WordPress 3.3

  36. Gravatar Icon 36 Yukoner Posted January 28th, 2012 - 04:02

    Love the plugin! Just wondering if you are going to implement a random function for the slideshow shortcode?

  37. Gravatar Icon 37 sclark Posted February 1st, 2012 - 19:22

    Is there a way to show a slideshow with only specific tags? I don’t want to duplicate the photos into another album but I need to pull only specifically tagged photos from my main album into a slideshow onto one of my pages. Can you please post the shortcode to do this? I see the shortcode to do it with just a gallery, but I need JUST A SLIDESHOW, no gallery thumbs, and just the ones that have a tag of “passport”.

  38. Gravatar Icon 38 Shayne Lawrence Posted March 16th, 2012 - 19:25

    Hi there,

    I recently uploaded a few galleries to http://www.blazingsaddle.ca and they went fine, as you can see but as of today the plugin won’t let me upload images. I can add new galleries just fine but when I go to add images, select the image and the gallery to upload to and then click the “Upload” button it does absolutely nothing. No error, no response. Have tried it in two different users with no luck. Please help!

    I’ve had no luck getting any kind of support or replies on inquiries about this plugin on the forum up to this point and while I prefer it I can’t use it if it won’t work. And if I found there was some support for it so that it would work I’d happily make a donation. :(

  39. Gravatar Icon 39 Lobius Posted March 20th, 2012 - 02:37

    Slideshow isn’t working right.

    It produces a blank slide at the start.

    I cannot find anything in options.

    Any ideas?

    My development server: http://50.57.160.130/daco/

    Thanks.

  40. Gravatar Icon 40 bobby den Posted March 25th, 2012 - 17:53

    why when i use nggDisplayRandomImages got that in my html non breakin space entry-content is annoying, that destroy the design of the page…i feel was ok before update any clue

    thanks

  41. Gravatar Icon 41 dolec Posted March 27th, 2012 - 13:10

    Slideshow doesnt work it only shows loading icon what can cause the problem? Gallery works fine but when use : slideshow tag nothing happens:)

  42. Gravatar Icon 42 Laxi Posted April 2nd, 2012 - 21:40

    Hello there,

    I m Using NexGen Gallery on my website. and it gives me error while uploading image and making thumb

    Exceed Memory Limit: Require 31.2Mbyte

    Any idea how to fix this ?

  43. Gravatar Icon 43 pozicky Posted April 22nd, 2012 - 22:45

    same problom like Laxi

    Tom

  44. Gravatar Icon 44 Anette Posted April 23rd, 2012 - 21:58

    Hello,

    thank you for the nextgen gallery. Everything works fine, there’s only 1 little thing i can’t fix.
    In in IE8 Gallery Thumbnails show vertically streched.

    I’ve been google-ing two days allready to try to solve this.
    Different solutions, not one is working correctly.
    Who can give me THE ultimate solution?
    ( The theme I work with is Mosaico)

  45. Gravatar Icon 45 jim Posted April 26th, 2012 - 04:15

    Since upgrading(and being informed that it’s 100% compatible with my theme)I can no longer sort my gallery. When I go to sort it, all it gives me is a list-vertically aligned on the page. No pictures, no sorting ability. Any fixes planned?

  46. Gravatar Icon 46 Ken Fisher Posted June 3rd, 2012 - 10:50

    Hi

    I have purchased wordtube and it does nearly everything I require. The exception is to independantly order individual playlists. There seems a function to do this but I cant edit it and its always set to 0. I am new to wordpress so am I missing something? Any help would be appreciated.

  47. Gravatar Icon 47 Joel Posted June 4th, 2012 - 20:28

    I’m trying to figure out how to include the title text field as well as the description when the photo opens in the lightbox. So it would look like this

    Title of photo (hovering above photo)
    Photo
    Description
    Counter

    This seems like it would be something simple, but no one seems to have pursued this option. I tried the plugin “”NextGEN Custom Fields” which was promising, but then I can’t seem to find which php page to place the code in, or perhaps which css property to apply it to.

    Any thoughts?

    Thanks!

  48. Gravatar Icon 48 Shahee Posted June 26th, 2012 - 02:36

    [nggallery id=2] is loading gallery id 1 !?! why is this happening? I can’t seem to get any response on the forums.

Comments are currently closed.